Help getting my first sensor working please

6 years 6 months ago #941 by HarryDutch
This is really a tough one! I know how frustrating this must be. But hold on. I will stay with you as long as it takes to solve this. Some other things to try:

I assume you have double and tripple checked all your connections. Have you checked the connections between the radio and your Arduino nano with the continuity tester of your multimeter? Maybe there's a bad connection on your breadboard.
Have you tried to replace the nano with an Arduino pro mini 3.3v? Just to make sure that it has nothing to do with the microcontroller.

Have you visited the site www.mysensors.org ? Have a look at their forum. You can ask there questions about EasyIoT too.

Please Log in or Create an account to join the conversation.

6 years 6 months ago - 6 years 6 months ago #943 by PaulRB
Thanks I really appreciate your assistance.

Arduino/breadboard connections tested with multimeter. None more than 1 ohm. My multimeter was cheap, so I don't know how reliable it is with very low resistances, but I think it would tell me if there was a real problem with the connections.

Here are the detailed images:



I don't have a 3V3 Mini, but I do have a second Nano 3. Swapped that in, its 3V3 output measures 3.4V. No different output.

I have a Pro Micro also, but that has no 3V3 output and I don't have any 3V3 regulators. I suppose I could use a couple of diodes to drop a volt or so off the 5V. But the fact that the second Nano behaves the same as the first seems to tell me that there's not much point trying the Pro Micro. What do you think?

I had searched the mysensors forum, just before I posted here. Found one or two similar posts, followed with updates that everything was now working fine, their fixes didn't apply to my circuit. I will have another browse.

As for posting a question there, I was unable to register as a forum member! I tried a dozen times, filling out the form and entering the CAPTCHA code correctly and clicking "Register Now", only to be told a minute later that there had been a session timeout error. Perhaps it was a problem with their server that day, I will try again. UPDATE: just tried registering again, no luck.

Please Log in or Create an account to join the conversation.

6 years 6 months ago #944 by HarryDutch
Weird that you cannot finish your registration at MySensors. Let me know if it's still a problem after you tried it tomorrow. Could be a server problem over there.

Are you using the latest Arduino IDE (1.6.1)?

Instead of using a dynamic ID for your sensor (which is clearly not working right now) you could use a static ID. Change gw.begin() into gw.begin(NULL, 15). 15 = static node id which you can change to any number (but not 0 and 255 and 254).

Please Log in or Create an account to join the conversation.

6 years 6 months ago #945 by PaulRB
Yes, Arduino 1.6.1

Changed gw.begin(NULL, 15) as suggested, here is the new output:
sensor started, id 15
send: 15-15-255-0 s=255,c=0,t=17,pt=0,l=5,st=fail:1.4.1
send: 15-15-255-0 s=255,c=3,t=6,pt=1,l=1,st=fail:255
send: 15-15-255-0 s=255,c=3,t=11,pt=0,l=8,st=fail:Humidity
send: 15-15-255-0 s=255,c=3,t=12,pt=0,l=3,st=fail:1.0
send: 15-15-255-0 s=0,c=0,t=7,pt=0,l=5,st=fail:1.4.1
send: 15-15-255-0 s=1,c=0,t=6,pt=0,l=5,st=fail:1.4.1
send: 15-15-255-0 s=1,c=1,t=0,pt=7,l=5,st=fail:22.0
send: 15-15-255-255 s=255,c=3,t=7,pt=0,l=0,st=fail:
T: 22.00
send: 15-15-255-0 s=0,c=1,t=1,pt=7,l=5,st=fail:36.0
H: 36.00

Still getting Timeout from Add Node on the web interface.

Have also been trying the ping_test example sketch from the NRF library, with both Nanos hooked up to their own radio modules. Results were dissapointing, with about 50% failures.

Both nrf modules are only a metre or so away from my wifi router. Could the wifi signal be interfering? Does anyone use EasyIot on a PI with a wifi dongle, because I guess that would not work either if wifi interferes with the nrf radio modules.

Please Log in or Create an account to join the conversation.

6 years 6 months ago - 6 years 6 months ago #946 by HarryDutch
So there is some communication between the 2 nodes. I don't think interference is the cause of you problem. I have my PI and a test radio very close to my WiFi router and had never problems with interference.

Because there is some communication between the 2 radios you could try to solder a bigger cap (I use 47 uF and some even use 100 uF) directly across VCC and GND on your sensor radio and the radio on the PI. Don't forget to clean the EEPROM on your sensor.

Please Log in or Create an account to join the conversation.

6 years 6 months ago #947 by PaulRB
I'm using 100uF on one and 470uF on the other. They were pretty close to the power pins of the radio modules, but I have moved them as close up to the radio modules as I can. I have also added small caps, 0.1uF, also as close as poss to the component's power pins. Absolutely no change, I'm afraid.

I wonder if I have particularly poor quality radio modules. Unfortunately almost all the other ones on eBay look exactly the same as mine! I have seen some with metal covers, but they are much more expensive.

One of the 3 modules I have is a high-power one with a detacheable antenna. I've tried swapping that for each of the two smaller modules (the ones with antenna on the pcb) but this also has not helped.

Another possible source of interference is my 3G dongle. Having no DSL available at the property, I use this as my internet connection. It is plugged into the wifi router, also less than a metre away. I might try disconnecting that temporarily later.

Please Log in or Create an account to join the conversation.

Time to create page: 0.236 seconds

Forum latest

  • No posts to display.