Mqtt disables

6 years 1 week ago #2225 by piman
Replied by piman on topic Mqtt disables
For some reason the contents of my file does not look like this is what's in my file<?xml version="1.0" encoding="utf-8"?>
<SystemConfig xmlns:xsi=" www.w3.org/2001/XMLSchema-instance " xmlns:xsd=" www.w3.org/2001/XMLSchema ">
<Drivers>
<Driver>
<Domain>MySensors</Domain>
<Enabled>true</Enabled>
</Driver>
<Driver>
<Domain>RPiGPIO</Domain>
<Enabled>true</Enabled>
</Driver>
<Driver>
<Domain>Esp8266</Domain>
<Enabled>true</Enabled>
</Driver>
<Driver>
<Domain>Virtual</Domain>
<Enabled>false</Enabled>
</Driver>
</Drivers>
<WebInterface>
<Users>
<WebServiceUser>
<Username>admin</Username>
<Password>DF578F8C35C6ACA3E946F5967542EAA9BE6FD9C6</Password>
<RoleId>1</RoleId>
</WebServiceUser>
</Users>
<HttpPort>80</HttpPort>
<SslPort>1301</SslPort>
<ForceSSL>false</ForceSSL>
<EnableLogging>true</EnableLogging>
</WebInterface>
<SmsGateway>
<Enabled>false</Enabled>
<PortName>/dev/ttyUSB0</PortName>
<BaudRate>19200</BaudRate>
<AlowedSender>*</AlowedSender>
<DebugMode>false</DebugMode>
<SMSCharRegex>[^A-Za-z0-9 \r\n@£$¥èéùìòÇØøÅåΔ_ΦΓΛΩΠΨΣΘΞÆæßÉ!"#$%&amp;'()*+,\-./:;&lt;=&gt;?¡ÄÖÑܧ¿äöñüà^{}\\\[~\]|€]</SMSCharRegex>
<SMSShortcutCollection />
</SmsGateway>
<ServerId>c68b9215-8f2b-4e6c-8bde-12f61f9874ed</ServerId>
</SystemConfig>

I'll try to make the alterations and see if that fixes thanks for your reply

Please Log in or Create an account to join the conversation.

6 years 1 week ago #2226 by EasyIoT
Replied by EasyIoT on topic Mqtt disables

piman wrote: For some reason the contents of my file does not look like this is what's in my file<?xml version="1.0" encoding="utf-8"?>
<SystemConfig xmlns:xsi=" www.w3.org/2001/XMLSchema-instance " xmlns:xsd=" www.w3.org/2001/XMLSchema ">
<Drivers>
<Driver>
<Domain>MySensors</Domain>
<Enabled>true</Enabled>
</Driver>
<Driver>
<Domain>RPiGPIO</Domain>
<Enabled>true</Enabled>
</Driver>
<Driver>
<Domain>Esp8266</Domain>
<Enabled>true</Enabled>
</Driver>
<Driver>
<Domain>Virtual</Domain>
<Enabled>false</Enabled>
</Driver>
</Drivers>
<WebInterface>
<Users>
<WebServiceUser>
<Username>admin</Username>
<Password>DF578F8C35C6ACA3E946F5967542EAA9BE6FD9C6</Password>
<RoleId>1</RoleId>
</WebServiceUser>
</Users>
<HttpPort>80</HttpPort>
<SslPort>1301</SslPort>
<ForceSSL>false</ForceSSL>
<EnableLogging>true</EnableLogging>
</WebInterface>
<SmsGateway>
<Enabled>false</Enabled>
<PortName>/dev/ttyUSB0</PortName>
<BaudRate>19200</BaudRate>
<AlowedSender>*</AlowedSender>
<DebugMode>false</DebugMode>
<SMSCharRegex>[^A-Za-z0-9 \r\n@£$¥èéùìòÇØøÅåΔ_ΦΓΛΩΠΨΣΘΞÆæßÉ!"#$%&amp;'()*+,\-./:;&lt;=&gt;?¡ÄÖÑܧ¿äöñüà^{}\\\[~\]|€]</SMSCharRegex>
<SMSShortcutCollection />
</SmsGateway>
<ServerId>c68b9215-8f2b-4e6c-8bde-12f61f9874ed</ServerId>
</SystemConfig>

I'll try to make the alterations and see if that fixes thanks for your reply


I dindn't post all file just driver section. In your file mqtt driver is missing.

Please Log in or Create an account to join the conversation.

6 years 1 week ago #2254 by piman
Replied by piman on topic Mqtt disables
@EasyIoT, thank you for your suggestion however I had a problem modifying the file, it would not allow me to do this, so I made a copy and modified that, and then replaced my original file with my new file with the amended section, this still doesn't solve the problem because EasyIoT server overwrites the file with the previous data therefore removing my amended section.
Having this problem lead me to check the virtual server to only find,the problem is still there. I can enable and disable it but it makes no difference because the data is still continues to come through as well as the debug information.
This is the same for v8.
ps: I am using v9.

Please Log in or Create an account to join the conversation.

6 years 1 week ago #2269 by EasyIoT
Replied by EasyIoT on topic Mqtt disables

piman wrote: @EasyIoT, thank you for your suggestion however I had a problem modifying the file, it would not allow me to do this, so I made a copy and modified that, and then replaced my original file with my new file with the amended section, this still doesn't solve the problem because EasyIoT server overwrites the file with the previous data therefore removing my amended section.
Having this problem lead me to check the virtual server to only find,the problem is still there. I can enable and disable it but it makes no difference because the data is still continues to come through as well as the debug information.
This is the same for v8.
ps: I am using v9.


Before you change file stop EasyIoT server. If you need also change read/write permissions. After change start EasyIoT server and it will work.
The following user(s) said Thank You: piman

Please Log in or Create an account to join the conversation.

6 years 1 week ago #2281 by piman
Replied by piman on topic Mqtt disables
@EasyIoT, thanks that worked as you said:)

Please Log in or Create an account to join the conversation.

Time to create page: 0.238 seconds