Mqtt disables

6 years 2 weeks ago #2128 by piman
Mqtt disables was created by piman
I am trying out MQTT client and find that when the server resets MQTT client disables itself, and you have to reenable it manually is there a fix for this.
Thanks Andy.

Please Log in or Create an account to join the conversation.

6 years 2 weeks ago #2147 by EasyIoT
Replied by EasyIoT on topic Mqtt disables

piman wrote: I am trying out MQTT client and find that when the server resets MQTT client disables itself, and you have to reenable it manually is there a fix for this.
Thanks Andy.


Can you describe test case? What do you mean by "server resets MQTT"?

Please Log in or Create an account to join the conversation.

6 years 1 week ago #2206 by neofox2k
Replied by neofox2k on topic Mqtt disables
hello, It's the same to me, each time I reset the server (raspberry pi) the MQTT client driver is disabled. Also happens with a Virtual Output, the best situation to me it is that de Virtual Output remember the last state.


Thanks for all, it's a great job

Please Log in or Create an account to join the conversation.

6 years 3 days ago #2220 by EasyIoT
Replied by EasyIoT on topic Mqtt disables

neofox2k wrote: hello, It's the same to me, each time I reset the server (raspberry pi) the MQTT client driver is disabled. Also happens with a Virtual Output, the best situation to me it is that de Virtual Output remember the last state.


Thanks for all, it's a great job


Did you shut down EasyIoT server in Web interface (Configure->General settings->Shut down server) before restarting RPI. If EasyIoT server is not shut down correctly, then some settings are not saved.
The following user(s) said Thank You: piman

Please Log in or Create an account to join the conversation.

6 years 2 days ago #2223 by piman
Replied by piman on topic Mqtt disables
In my case this is how I shut down my server all the time unless there has been a power outage. However for me virtual outputs does not suffer the same problem it seems to be working fine.
Thanks.

Please Log in or Create an account to join the conversation.

6 years 2 days ago #2224 by EasyIoT
Replied by EasyIoT on topic Mqtt disables

piman wrote: In my case this is how I shut down my server all the time unless there has been a power outage. However for me virtual outputs does not suffer the same problem it seems to be working fine.
Thanks.


Check systemconfig.xml in config folder. If driver is missing add driver configuration and it will work. This are all drivers:

<Drivers>
<Driver>
<Domain>MySensors</Domain>
<Enabled>true</Enabled>
</Driver>
<Driver>
<Domain>RPiGPIO</Domain>
<Enabled>true</Enabled>
</Driver>
<Driver>
<Domain>Esp8266</Domain>
<Enabled>false</Enabled>
</Driver>
<Driver>
<Domain>Virtual</Domain>
<Enabled>true</Enabled>
</Driver>
<Driver>
<Domain>MQTTClient</Domain>
<Enabled>true</Enabled>
</Driver>
</Drivers>

Please Log in or Create an account to join the conversation.

Time to create page: 0.225 seconds