× General topics about hardware.

SPI

6 years 8 months ago #430 by Lars65
SPI was created by Lars65
Hello All!
I am really new to this, and I need som help.
I have connected the nrf24 to the pins as it says, and I have enabled SPI.
But still do I get check wires when I try to start up the server.
Anyone had any idea?

Please Log in or Create an account to join the conversation.

6 years 8 months ago #443 by EasyIoT
Replied by EasyIoT on topic SPI
If wires are connected correctly and you use RPi image it should work.

Please Log in or Create an account to join the conversation.

6 years 8 months ago #455 by Lars65
Replied by Lars65 on topic SPI
That's what I thought too. I use those nrf24 on arduino without problems. I have checked all over internet of connections, but still it doesn't work. my raspberry is a B+ V1.2. if I go in to /dev/ and run ls, I get spidev 0.0 and spidev 1.0. So if I don't have missed anything more then I should have SPI regarding to software, and then it should be an hardware issue. Or am I wrong?

Please Log in or Create an account to join the conversation.

6 years 8 months ago #459 by Lars65
Replied by Lars65 on topic SPI
I think I need a little bit rest. :)
I have the B+ bord, should start to count the amount of pins. :)

I have another question though.
When using the ESP8266, how is it connected to Rpi?
Do you take the 3.3v from pin 1 as you do for the NRF24?

Please Log in or Create an account to join the conversation.

6 years 8 months ago #463 by EasyIoT
Replied by EasyIoT on topic SPI
ESP8266 is connected only to Arduino. RPi uses network cable or USB WiFi dongle.

Please Log in or Create an account to join the conversation.

6 years 7 months ago #467 by Lars65
Replied by Lars65 on topic SPI
it's a great piece of software this.
I have the server up and running.
My problem now is that I can't connect my nodes.
Is there any special settings for the radio that I have to take care of?

Channel is set to 90
base radio id is: 0xA8A8E1FC00
data rate is set to 250kps
Power amplifi leveö is set to PA MAX

Please Log in or Create an account to join the conversation.

Time to create page: 0.236 seconds

Forum latest

  • No posts to display.