Configuring MySensor nodes

6 years 8 months ago #244 by pvoj
Replied by pvoj on topic Configuring MySensor nodes

EasyIoT wrote:

bobl wrote: How do you clear the eeprom? Thanks

use this program
github.com/iot-playground/Arduino/blob/m...rom/clear_eeprom.ino

Yes, I use the same script. There is no node_id assigned to the node right now.
Can I set the node_id manually? I mean the following steps:
- clear eprom
- boot up the node and the inclusive mode on EasyIoT.
- catch the given node_id (from the logs)
- send and set the new node_id from a serial monitor
Is it working theoretically? (I think no - except if I modify the config files manually)
I will be able to play with it tonight.

Please Log in or Create an account to join the conversation.

6 years 8 months ago #245 by EasyIoT
Replied by EasyIoT on topic Configuring MySensor nodes

pvoj wrote:

EasyIoT wrote:

bobl wrote: How do you clear the eeprom? Thanks

use this program
github.com/iot-playground/Arduino/blob/m...rom/clear_eeprom.ino

Yes, I use the same script. There is no node_id assigned to the node right now.
Can I set the node_id manually? I mean the following steps:
- clear eprom
- boot up the node and the inclusive mode on EasyIoT.
- catch the given node_id (from the logs)
- send and set the new node_id from a serial monitor
Is it working theoretically? (I think no - except if I modify the config files manually)
I will be able to play with it tonight.


I did not test this procedure, but why do you want to do this. It should work with standard procedure. Sometimes I have to add the same node 2 times if first time is not successful. And there is no need to clear eeprom after first try.
The following user(s) said Thank You: pvoj

Please Log in or Create an account to join the conversation.

6 years 8 months ago #248 by bobl
Replied by bobl on topic Configuring MySensor nodes
Clearing the eeprom did the trick! I now have a dimmer!! Thanks for this nice program.

Please Log in or Create an account to join the conversation.

6 years 8 months ago #277 by pvoj
Replied by pvoj on topic Configuring MySensor nodes

EasyIoT wrote:

pvoj wrote:

EasyIoT wrote: Hi, your procedure is right. Clerar eeprom with program, then press button add node in web interface and switch on node. Be careful to use correct channel and speed on both sides Arduino and Raspbery. For troubleshooting I recommend to run in console mode and see debug output.

Thanks for the fast advice it realy helped! The communication looks ok. There is a problem around mysensors library if the node fails to receive the new id.
Here is the log which repeats nearly every second the communication repeats:
2015-02-02T00:28:17.6822510+01:00       DEBUG   MySensors                               Send: 0-0-255-255s=255,c=3,t=4,pt=1,l=1,st=fail:6
2015-02-02T00:28:19.6605210+01:00       DEBUG   MySensors                               Read: 255-255-0 s=255,c=3,t=3,pt=0,l=0:
2015-02-02T00:28:19.6761890+01:00       DEBUG   MySensors                               Requesr for new node Id
2015-02-02T00:28:19.6815680+01:00       DEBUG   MySensors                               New node id:6
write
false


Then try add node again. If node is without id it will not work. Also if node is not added to server it will not work.


Problem solved! :-)
I have tried it with several other nodes. There were working and non-working nodes. The main difference was in the wiring between working and non-working nodes.
I use a 3.3V regulated power input. When the radio is fed from the same power input as the arduino pro mini 3.3V (to raw) - directly from the power supply - the config did not work.
When I feed the radio vcc from the arduino vcc, the node_id is accepted. Funny, but at least it is working.
Thanks for your help!
(the next step will be switching relay nodes based on values of user settings and measured temperatures - thermostat function)

Please Log in or Create an account to join the conversation.

6 years 8 months ago - 6 years 8 months ago #284 by skywatch
Replied by skywatch on topic Configuring MySensor nodes
It might be that the pro mini has a capacitor that is smoothing the 3.3V supply to the radio.

You can add a 47uF electrolytic (or tantalum) capacitor across the GND and VCC on the radio module and it might well be OK again.

I did this today to 13 modules and all are nice and stable now.

Also of note is that you seem to be putting 3.3v into the RAW pin. The RAW input is for voltages higher than the modules voltage and therefore needs to go through the on board regulator. If you have 3.3V already it should go directly to the VCC pin (and of course GND).

Skywatch,.

Please Log in or Create an account to join the conversation.

Time to create page: 0.239 seconds

Forum latest

  • No posts to display.