× General topics about hardware.

facing problem in uploading Firmware to ESP8266

5 years 9 months ago #2701 by calibrearun@gmail.com
Hey I am facing problem in uploading the ESP8266 V0.9.5.2 firmware. I just followed the post ESP8266 firmware update in the site .
And for uploading i use XTCOM_UTILITY,it is giving the error as "Failed to connect with target".In my case ESP8266 01 is getting the power, but it is giving error. Can any one give me a solution for this.

My second question is whether the ESP8266 is comes with an firmware.If in this case how can i know the firmware used.

Please Log in or Create an account to join the conversation.

5 years 9 months ago #2709 by samnet
i hav the same problem ... ist it maybe not enough power?
i can open the comport but didn t connect to device

Please Log in or Create an account to join the conversation.

5 years 9 months ago #2710 by calibrearun@gmail.com
Hey can you post the image of your connection of ESP8266 firmware upload.so that we can come with the right solution.

Please Log in or Create an account to join the conversation.

5 years 8 months ago #2711 by Ruettimann
Hi, first of all I agree, please post as much info as possible to get a useful answer ... please.

ESP-01 is normally delivered with "AT" firmware, which is used for serial control with arduino.
You must upload NodeMCU firmware first.

I do a lot with ESP8266 and sometimes it is tricky to get it into flash mode.

Here are my hints:
- Read this tutorial, it is worth the price!
randomnerdtutorials.com/home-automation-using-esp8266/
- ESP goes into flash mode during bootup if right pins are grounded, make sure you give power after
putting all the other connectors.
- Build this hepler board makes it a lot easier to work with ESP-01 modules:

- Play around first with nodemcu dev board, it is not expensive
NodeMCU Board

cheers
chris

Please Log in or Create an account to join the conversation.

Time to create page: 0.214 seconds