Problem after maintenance.

1 year 4 months ago #3639 by bliny
I've got configured two modules, one was esp8266 with ds28b20, second was nodemcu v3 with ds18b20, all was working fine. Yesterday i woke up, went to the cloud address, and i saw only one module, the first one. Then i tried to add the second module back, with the easy way (with cloud api), and with instance and param id method, and it's not working. Now i deleted first module too, and when i connecting it, it wont create modules

Please Log in or Create an account to join the conversation.

1 year 4 months ago - 1 year 4 months ago #3640 by EasyIoT

bliny wrote: I've got configured two modules, one was esp8266 with ds28b20, second was nodemcu v3 with ds18b20, all was working fine. Yesterday i woke up, went to the cloud address, and i saw only one module, the first one. Then i tried to add the second module back, with the easy way (with cloud api), and with instance and param id method, and it's not working. Now i deleted first module too, and when i connecting it, it wont create modules


We tested MQTT and REST V1 API and it seems everything is OK. If you are using MQTT API or REST V1 API be sure to erase EEPROM before to delete module ID if you are adding new module.

You do not need to change URL cloud.iot-playground.com to easyiot-cloud.com, because they are pointed to the same IP address.

In new EasyIOT Cloud there are some changes:
-in EasyIoT Cloud Free package is max. number of modules 4 (configure->Account limits->Module limit)
-if you login with incorrect password (WEB interface or MQTT broker) too many times, your IP address is banned for some time for security reasons

Please Log in or Create an account to join the conversation.

1 year 4 months ago #3641 by bliny
I used this program github.com/iot-playground/EasyIoT-Cloud/...or_REST_v1_0.ino.ino It's based on EIoTCloudRestApiV1.0.

How to erase eeprom? I can't find it.

Please Log in or Create an account to join the conversation.

1 year 4 months ago #3642 by EasyIoT

bliny wrote: I used this program github.com/iot-playground/EasyIoT-Cloud/...or_REST_v1_0.ino.ino It's based on EIoTCloudRestApiV1.0.

How to erase eeprom? I can't find it.


We also tested REST V1 API and it works perfectly.
You can erase EEPROM with program to fill EEPROM with 0x00 or 0xFF values. Or just change #define CONFIG_VERSION "v01" to #define CONFIG_VERSION "v02" or some other value and it will skip old configuration and go in procedure to add new module. After you added module to cloud log off and log on to see new module.

Please Log in or Create an account to join the conversation.

1 year 4 months ago #3643 by bordor
Hi,

I need help. I configured my account and started tests las week. After maintenance i can't enter the server - when i try to connect to easyiot-cloud.com/ from firefox or opera i get message that connection has timed out. I cleared cache but problem stil persists. android not working too (both browser and app)

Please Log in or Create an account to join the conversation.

1 year 4 months ago #3644 by EasyIoT

bordor wrote: Hi,

I need help. I configured my account and started tests las week. After maintenance i can't enter the server - when i try to connect to easyiot-cloud.com/ from firefox or opera i get message that connection has timed out. I cleared cache but problem stil persists. android not working too (both browser and app)


Hi, we implemented security mechanism on new server. If there are too many incorrect logins over WEB interface, mobile application or MQTT API from specific IP address then system blocks IP address for some period of time.
If you do not see easyiot-cloud.com you somehow trigger this protection. This is temporary, after some time your IP will be unblocked.

Please Log in or Create an account to join the conversation.

Time to create page: 0.335 seconds