No autostart on Pi after EasyIoT upgrade

6 years 10 months ago #1822 by jilldris
I have used the rasbian image for the first install of EasyIoT. The EasyIoT server then autostarted as last thing of the boot sequene. However after updateing EasyIoT to later version the server does not seem to start, it looks ok in the boot sequence but when trying to access the webbserver it is not possible. I then need to start it manually with "sudo mono EasyIoT.exe" then it works ok.

Is there something that needs to be done that i have missed?

Please Log in or Create an account to join the conversation.

6 years 10 months ago #1823 by piman
Are you using the latest rasp-pi img?

Please Log in or Create an account to join the conversation.

6 years 10 months ago #1825 by jilldris
No it is from a few versions back. If I would install the latest image the autostart will probably work again, but I would like to avoid replacing the complete image every time there is a new easyiot version. Everytime a replace the easyiot files with those from a new version the autostart seems to stop working.

Please Log in or Create an account to join the conversation.

6 years 10 months ago #1826 by piman
It sounds like you've written over your configuration file,
"extract all files from new installation except config, log and programs folder (in config folder is your configuration) and keep EasyIoTDatabase.sqlite (history data)" more info:-
iot-playground.com/download .

Please Log in or Create an account to join the conversation.

6 years 10 months ago #1827 by asm7100
I put this in the 2ed last line in /etc/rc.local

sudo mono /home/easyiot/EasyIoT.exe

//
Allan

Please Log in or Create an account to join the conversation.

6 years 10 months ago #1834 by jilldris
Thanks for the answears.

I have followed those instruction and kept the config folder but I can of course have made something wrong.

I added the line in rc.local and that works fine but then it doesn't run in the background.

Please Log in or Create an account to join the conversation.

Time to create page: 0.244 seconds

Forum latest

  • No posts to display.