OneWire library version (ESP8266_DS18B20)

2 years 1 month ago #3337 by christoams
Hi,

I've a compilation error with "ESP8266_DS18B20_temperature_sensor_REST_v1_0":

OneWire.h:108: error: #error "Please define I/O register types here"

I've try a lot of OneWire library version but without sucess... :(

Some one have the right version please of OneWire for ESp8266?
Thanks a lot

Please Log in or Create an account to join the conversation.

2 years 1 month ago - 2 years 1 month ago #3347 by christoams
It's ok now, just used the arduino IDE version 1.6.5 and not the new version (library is not compatible)....

Please Log in or Create an account to join the conversation.

2 years 1 month ago #3355 by EasyIoT

christoams wrote: It's ok now, just used the arduino IDE version 1.6.5 and not the new version (library is not compatible)....


It looks like there are problems if you are using latest Arduino IDE. I'm also using 1.6.5 and it works stable.

Please Log in or Create an account to join the conversation.

Time to create page: 0.181 seconds