Welcome, Guest
Username: Password: Remember me

TOPIC: #/ subscription is enable

#/ subscription is enable 1 year 3 months ago #3309

  • Zaitsev
  • Zaitsev's Avatar
  • Offline
  • New Member
  • Posts: 11
  • Karma: 0
It is possible for everybody read data of everybody - not so good for professional service.
I also propose enabling subscription to $SYS/#.

[admin] removed picture, because of visible ID's
Last Edit: 1 year 2 months ago by EasyIoT.
The administrator has disabled public write access.

#/ subscription is enable 1 year 2 months ago #3313

  • EasyIoT
  • EasyIoT's Avatar
  • Offline
  • Administrator
  • Posts: 833
  • Thank you received: 258
  • Karma: 24
Zaitsev wrote:
It is possible for everybody read data of everybody - not so good for professional service.
I also propose enabling subscription to $SYS/#.


Thx for report. That's why it's still beta :)
/# is now disabled. You can only subscribe to your data topic /Db/[instance id]/#.
The administrator has disabled public write access.

#/ subscription is enable 1 year 2 months ago #3315

  • maesa
  • maesa's Avatar
  • Offline
  • New Member
  • Posts: 5
  • Karma: 0
I believe that it means that I cannot use a custom MQTT topic like /MyTopic/Something but should rather use /Db/[instance id]/MyTopic/Something.
At least, it explains why my subscriptions to /MyTopic/+ do not give any result anymore... :huh:

Fortunately, it is currently still possible to publish to /MyTopic/Something, so I can still follow the status of my IoT components through your Web interface. Do you plan to disable publishing to /MyTopic as well and, if so, when ? I believe that the fact that it is still possible means that I could probably publish to /Db/[someone else's instance]/#...
The administrator has disabled public write access.

#/ subscription is enable 1 year 2 months ago #3316

  • maesa
  • maesa's Avatar
  • Offline
  • New Member
  • Posts: 5
  • Karma: 0
Hum... My tests seem to show that only a subscription to /Db/[instance id]/+ is still working, but not e.g. /Db/[instance id]/MyTopic/#.
Isn't that too restrictive? Would it be possible e.g. to use wildcards only if the topic begins with /Db/[instance id]/ but is possibly longer? It would allow multiple clients to listen to specific topics within the same instance...
The administrator has disabled public write access.

#/ subscription is enable 1 year 2 months ago #3317

  • EasyIoT
  • EasyIoT's Avatar
  • Offline
  • Administrator
  • Posts: 833
  • Thank you received: 258
  • Karma: 24
maesa wrote:
I believe that it means that I cannot use a custom MQTT topic like /MyTopic/Something but should rather use /Db/[instance id]/MyTopic/Something.
At least, it explains why my subscriptions to /MyTopic/+ do not give any result anymore... :huh:

Fortunately, it is currently still possible to publish to /MyTopic/Something, so I can still follow the status of my IoT components through your Web interface. Do you plan to disable publishing to /MyTopic as well and, if so, when ? I believe that the fact that it is still possible means that I could probably publish to /Db/[someone else's instance]/#...

Currently you can only publish to custom /MyTopic/Something, subscribe does not work. We are searching for solution. This was quick fix to disable /#. Subscribe and publish to standard topic works ok.
Regarding to publish to someone else's instance - you do not know this instance and full topic. Even if you know it then username and password is checked before updating value.
Last Edit: 1 year 2 months ago by EasyIoT.
The administrator has disabled public write access.

#/ subscription is enable 1 year 2 months ago #3320

  • EasyIoT
  • EasyIoT's Avatar
  • Offline
  • Administrator
  • Posts: 833
  • Thank you received: 258
  • Karma: 24
I'm thinking to simplify things and skip /Db/[instance id]/ entirely. This will break backward compatibility, but it will significantly simplify design. MQTT topics for parameter will be just /[module id]/[parameter name] or [custom topic]. Also /Db/InstanceId topic no longer will be needed. Also /# or /[cutom topics]/# will work. Since Cloud is in beta I think it's still time to change this.
The administrator has disabled public write access.
Time to create page: 0.113 seconds
Powered by Kunena Forum