Problem starting with SSH.

3 years 3 months ago #779 by skywatch
HI,

When starting Eiot from SSH it only runs the web server until while the terminal window is open in windows. Closing this closes the server. When starting from the command line on the pi, it works all the time.

This means that currently it can't be started or restarted remotely without leaveing the laptop connected to it.

Skywatch

Please Log in or Create an account to join the conversation.

3 years 3 months ago #783 by EasyIoT

skywatch wrote: HI,

When starting Eiot from SSH it only runs the web server until while the terminal window is open in windows. Closing this closes the server. When starting from the command line on the pi, it works all the time.

This means that currently it can't be started or restarted remotely without leaveing the laptop connected to it.

Skywatch


If you also report which EasyIoT server version, Windows version and some console output when server is closed it will be much easier to find where is the problem.

Please Log in or Create an account to join the conversation.

3 years 3 months ago #792 by skywatch
win7x64 with eiot0.7b (latest on rpi2).

Will check rpi output tomorrow.

Please Log in or Create an account to join the conversation.

3 years 3 months ago #794 by Xavier
It's true if you run it with command:
sudo mono ./easyiot.exe
If you run EasyIoT as a service, as explained here , it will keep running if you close the ssh session (but running that way won't show you the debug output).

Please Log in or Create an account to join the conversation.

3 years 3 months ago #798 by skywatch
That works but only after I modified the script 'easyioy' (sp?) that we are told to download.

In the script the line
INSTALL_PATH="/home/pi/"

Needs to be changed to

INSTALL_PATH="/home"

Then it works as advertised.

Thanks for the pointerXavier :)

Skywatch

Please Log in or Create an account to join the conversation.

Time to create page: 0.211 seconds