Arduino LowP Initial Setup and other issues

6 years 4 months ago - 6 years 4 months ago #1211 by cdj
Hi folks,
I'm just building Arduino Low Power Door Window Sensor
and have following problem :

1) EasyIOT Installation NRF + RPI Follow Raspberry Pi A Pinout. If we check Raspberry Pi B+ (mine) pinout on THIS IMAGE we can find easyly : 3.3V,GND,SPI_MOSI, SPI_MISO, but where to connect CE, CSN and SCK to RPI ?
EDIT : OK FOUND.... THEY ARE IN THE SAME POSITIONS... :sick: BUT EASYIOT CONSOLE GIVE ME A CHECK WIRES ???

EDIT: OK A false contact... IT WORKS!

2) I'm using an Arduino UNO as programmer to burn fuses (after removing regulator and led) of Pro Mini 3.3v. Following THIS GUIDE i don't understand if i must put a capacitor of 10mf or 10nf between rst and gnd of my UNO (as programmer).
Without this :
C:\>avrdude -c arduino -p m328p -P com3 -U lfus
e:w:0x62:m

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.00s

avrdude: Device signature = 0x1e950f
avrdude: reading input file "0x62"
avrdude: writing lfuse (1 bytes):

Writing |                                                    | 0% 0.00s ***faile
d;
Writing | ################################################## | 100% 0.11s

avrdude: 1 bytes of lfuse written
avrdude: verifying lfuse memory against 0x62:
avrdude: load data lfuse data from input file 0x62:
avrdude: input file 0x62 contains 1 bytes
avrdude: reading on-chip lfuse data:

Reading | ################################################## | 100% 0.00s

avrdude: verifying ...
avrdude: verification error, first mismatch at byte 0x0000
         0x62 != 0x00
avrdude: verification error; content mismatch

avrdude: safemode: lfuse changed! Was 62, and is now 0
Would you like this fuse to be changed back? [y/n] n
avrdude: safemode: Fuses OK
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.
C:\>avrdude -c arduino -p m328p -P com3 -U efus
e:w:0x07:m

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.00s

avrdude: Device signature = 0x1e950f
avrdude: reading input file "0x07"
avrdude: writing efuse (1 bytes):

Writing |                                                    | 0% 0.00s ***faile
d;
Writing | ################################################## | 100% 0.11s

avrdude: 1 bytes of efuse written
avrdude: verifying efuse memory against 0x07:
avrdude: load data efuse data from input file 0x07:
avrdude: input file 0x07 contains 1 bytes
avrdude: reading on-chip efuse data:

Reading | ################################################## | 100% 0.00s

avrdude: verifying ...
avrdude: verification error, first mismatch at byte 0x0000
         0x07 != 0x00
avrdude: verification error; content mismatch

avrdude: safemode: efuse changed! Was 7, and is now 0
Would you like this fuse to be changed back? [y/n] n
avrdude: safemode: Fuses OK
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.
What's Wrong?
EDIT : If i put a 10MF Capacitor between reset and gnd (of arduino uno used as programmer) it respond me :
C:\>avrdude -c arduino -p m328p -P com3 -U lfus
e:w:0x62:m
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude done.  Thank you.
3) When it works, If we put Arduino to work at 1,8v why we use two AA battery? We've removed regulator, is it works connecting 3.0v of batteries to VCC AND GND ?

Thanks a lot for helping and hope to solve soon !
Dario

Please Log in or Create an account to join the conversation.

6 years 4 months ago - 6 years 4 months ago #1244 by cdj
Please no one can give me correct avrdude output ?
If it doesn't work with arduinoISP can i burn fuses with my Silicon Labs CP210x USB to UART Bridge ? ? ?
avrdude -c what? i can't find driver.....

Some ideas ?

Thanks
Dario

EDIT : i suppose that i can't use Arduino to reset fuses : read on THIS LINK

Please Log in or Create an account to join the conversation.

6 years 4 months ago #1249 by cdj
OK tried with my cp210x usb to ttl.....
result is that i can program a sketch to arduino with ide and without problem (it works), but when i try to avrdude from command line :
C:\WinAVR-20100110>avrdude -c arduino -p m328p -P com5 -b57600 -U efuse:w:0x07:m


avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.00s

avrdude: Device signature = 0x1e950f
avrdude: reading input file "0x07"
avrdude: writing efuse (1 bytes):

Writing |                                                    | 0% 0.00s ***faile
d;
Writing | ################################################## | 100% 0.09s

avrdude: 1 bytes of efuse written
avrdude: verifying efuse memory against 0x07:
avrdude: load data efuse data from input file 0x07:
avrdude: input file 0x07 contains 1 bytes
avrdude: reading on-chip efuse data:

Reading | ################################################## | 100% 0.00s

avrdude: verifying ...
avrdude: verification error, first mismatch at byte 0x0000
         0x07 != 0x00
avrdude: verification error; content mismatch

avrdude: safemode: efuse changed! Was 7, and is now 0
Would you like this fuse to be changed back? [y/n] n
avrdude: safemode: Fuses OK
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.

Please someone help me, i'm becoming crazy !

Please Log in or Create an account to join the conversation.

6 years 4 months ago #1251 by HarryDutch

Please Log in or Create an account to join the conversation.

6 years 4 months ago - 6 years 4 months ago #1252 by cdj
Thanks Harry for reply, but if i use this gammon script i don't really know how to set fuse in pro mini....

But in this place there's something obvious but interesting...

Arduino uno is 5v and pro mini run at 3.3v.... so i suppose that i can't program it without level shifting ... but sketch loaded correctly!!! strange that i haven't burnt it !

Cp210x could be solution... but can't understand why give error....

Sorry but i'm a newbie of avr programming :)
What can i do ? thanks for help

Thanks
Dario

EDIT :
THIS IS MY CONNECTIONS :

USB TTL CP2102 | PRO MINI
3v3 | vcc
gnd | gnd
5v | not connected
TXD | RXI
RXD | TXO
DTR | DTR

Tried also to put extra 100nf capacitor between usb dtr and arduino rst

Why i can upload sketches and not program fuses ?

Please Log in or Create an account to join the conversation.

6 years 4 months ago - 6 years 4 months ago #1260 by cdj
C'mon MR.EASYIOT, give me a solution from your magic hat :)
Is it possible to use ArduinoISP with an Arduino Uno to burn fuses of Arduino Pro Micro ?
If NOT, Is it possible to use a CP210x to burn fuses of Arduino Pro Micro ?
HOW ? :(

EDIT : YESSSSS IT WORKS WITH ARDUINO UNO AS AVR PROGRAMMER WITH THIS COMMAND LINE :
avrdude -c arduino -v -p m328p -P com4 -b19200 -U efuse:w:0x07:m

It's very important to set -b19200 or it doesn't work!!!

Dario

Please Log in or Create an account to join the conversation.

Time to create page: 0.650 seconds