Welcome, Guest
Username: Password: Remember me

TOPIC: Bug in easyiot-cloud.com

Bug in easyiot-cloud.com 2 months 3 days ago #3725

  • Nikoloudakis
  • Nikoloudakis's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Thank you received: 2
  • Karma: 0
Hello. First of all thanks the "Super User" for his effort and for sharing his projects. I tried to construct the project "ESP8266 internet connected switch (EasyIoT Cloud MQTT API V1) - improved" but I had constantly errors in debugging. After a lot of effort I found some bugs and solutions in "easyiot-cloud.com".The default Modules in "Demo place" are working well but if you decide to add one, you encounter 2 bugs. First after subscribe new module command you constantly get moduleid "0"(if you have already 4 modules)(no bug), and if you add a module by hand in the http page, you cannot publish a value unless you change the topic in a custom format(if you add Parameter.Sensor by esp it is not working,if you add Parameter by http page it is working ok). I hope someone can replicate the second bug and if it is replicated hope super user to fix this because it cause a lot of frustration to users trying to construct projects using MQTT broker. Thank you again Super User for your time and effort
Last Edit: 2 months 3 days ago by Nikoloudakis. Reason: Found Solution
The administrator has disabled public write access.

Bug in easyiot-cloud.com 2 months 2 days ago #3726

  • EasyIoT
  • EasyIoT's Avatar
  • Offline
  • Administrator
  • Posts: 809
  • Thank you received: 252
  • Karma: 23
Nikoloudakis wrote:
Hello. First of all thanks the "Super User" for his effort and for sharing his projects. I tried to construct the project "ESP8266 internet connected switch (EasyIoT Cloud MQTT API V1) - improved" but I had constantly errors in debugging. After a lot of effort I found some bugs and solutions in "easyiot-cloud.com".The default Modules in "Demo place" are working well but if you decide to add one, you encounter 2 bugs. First after subscribe new module command you constantly get moduleid "0"(if you have already 4 modules)(no bug), and if you add a module by hand in the http page, you cannot publish a value unless you change the topic in a custom format(if you add Parameter.Sensor by esp it is not working,if you add Parameter by http page it is working ok). I hope someone can replicate the second bug and if it is replicated hope super user to fix this because it cause a lot of frustration to users trying to construct projects using MQTT broker. Thank you again Super User for your time and effort


Thank you for report. We will investigate your findings ASAP...
The administrator has disabled public write access.

Bug in easyiot-cloud.com 2 months 2 days ago #3727

  • EasyIoT
  • EasyIoT's Avatar
  • Offline
  • Administrator
  • Posts: 809
  • Thank you received: 252
  • Karma: 23
Nikoloudakis wrote:
Hello. First of all thanks the "Super User" for his effort and for sharing his projects. I tried to construct the project "ESP8266 internet connected switch (EasyIoT Cloud MQTT API V1) - improved" but I had constantly errors in debugging. After a lot of effort I found some bugs and solutions in "easyiot-cloud.com".The default Modules in "Demo place" are working well but if you decide to add one, you encounter 2 bugs. First after subscribe new module command you constantly get moduleid "0"(if you have already 4 modules)(no bug), and if you add a module by hand in the http page, you cannot publish a value unless you change the topic in a custom format(if you add Parameter.Sensor by esp it is not working,if you add Parameter by http page it is working ok). I hope someone can replicate the second bug and if it is replicated hope super user to fix this because it cause a lot of frustration to users trying to construct projects using MQTT broker. Thank you again Super User for your time and effort

We fixed this issue. The problem was after you remove module parameter topic was not correctly removed from MQTT.
Be careful: if you get module id 0 you've exceed maximum number of modules (configure->account limits).
And when you automatically add module to Cloud (not in web interface) you need to log off and log on again to refresh module list.
Last Edit: 2 months 1 day ago by EasyIoT.
The administrator has disabled public write access.
Time to create page: 0.126 seconds
Powered by Kunena Forum